STIGUI
V-282749CAT II — Medium severitySV-282749r1201227_rule

The TOSS 5 audit system must take appropriate action when an error writing to the audit storage volume occurs.

Rule version TOSS-05-000388 · STIG v1 · 2026-08-20

Discussion

It is critical that when the operating system is at risk of failing to process audit logs as required, it takes action to mitigate the failure. Audit processing failures include software/hardware errors; failures in the audit capturing mechanisms; and audit storage capacity being reached or exceeded. Responses to audit failure depend upon the nature of the failure mode.

Check

Verify TOSS 5 takes the appropriate action when an audit processing failure occurs using the following command:

$ sudo grep disk_error_action /etc/audit/auditd.conf

disk_error_action = HALT

If the value of the "disk_error_action" option is not "SYSLOG", "SINGLE", or "HALT", or the line is commented out, ask the system administrator (SA) to indicate how the system takes appropriate action when an audit process failure occurs. If there is no evidence of appropriate action, this is a finding.

Fix

Configure TOSS 5 to shut down by default upon audit failure (unless availability is an overriding concern).

Add or update the following line (depending on the configuration, "disk_error_action" can be set to "SYSLOG" or "SINGLE") in "/etc/audit/auditd.conf" file:

disk_error_action = HALT

If availability has been determined to be more important, and this decision is documented with the information system security officer (ISSO), configure the operating system to notify the SA and ISSO in the event of an audit processing failure by setting the "disk_error_action" to "SYSLOG".

Identifiers

Group ID
V-282749
Group title
SRG-OS-000480-GPOS-00227
Rule ID
SV-282749r1201227_rule
Check ID
C-87310r1201225_chk
Fix ID
F-87215r1201226_fix