STIGUI
V-282750CAT II — Medium severitySV-282750r1201230_rule

The TOSS 5 audit system must take appropriate action when the audit storage volume is full.

Rule version TOSS-05-000389 · STIG v1 · 2026-08-20

Discussion

It is critical that when the operating system is at risk of failing to process audit logs as required, it takes action to mitigate the failure. Audit processing failures include software/hardware errors; failures in the audit capturing mechanisms; and audit storage capacity being reached or exceeded. Responses to audit failure depend upon the nature of the failure mode.

Check

Verify TOSS 5 takes the appropriate action when the audit storage volume is full using the following command:

$ sudo grep disk_full_action /etc/audit/auditd.conf

disk_full_action = HALT

If the value of the "disk_full_action" option is not "SYSLOG", "SINGLE", or "HALT", or the line is commented out, ask the system administrator (SA) to indicate how the system takes appropriate action when an audit storage volume is full. If there is no evidence of appropriate action, this is a finding.

Fix

Configure TOSS 5 to shut down by default upon audit failure (unless availability is an overriding concern).

Add or update the following line (depending on the configuration, "disk_full_action" can be set to "SYSLOG" or "SINGLE") in "/etc/audit/auditd.conf" file:

disk_full_action = HALT

If availability has been determined to be more important, and this decision is documented with the information system security officer (ISSO), configure the operating system to notify the SA and ISSO in the event of an audit processing failure by setting the "disk_full_action" to "SYSLOG".

Identifiers

Group ID
V-282750
Group title
SRG-OS-000480-GPOS-00227
Rule ID
SV-282750r1201230_rule
Check ID
C-87311r1201228_chk
Fix ID
F-87216r1201229_fix